Results 1 to 16 of 16

Thread: DirectDraw error...

  1. #1

    DirectDraw Errors with ATI cards

    Hmm, I reformatted my comp and noticed that the only OS I can use is Win95 (I ain't touching that one again), Win98 (not touching that one either) and WinME. So I installed WinME, cause I've got incompatible hardware for WinXP and it won't install the darn thing.

    Anyway, I've got WinME... downloaded DirectX 8.1 and the very latest drivers to my Hercules 3D Prophet DLX 8500LE 128MB DDR.

    Installed AO as soon as I've got all the drivers working and sorted out the crashes. Problem with auto downloading the patches so I had to do manual download... installed.

    Launched AO, looking good. After a while I believe WinME crashed cause I couldn't do anything at all... mouse, keyboard well you name it freezed. Re-booted the computer and launched AO. Now everytime AO boots up it says... "Last time there was a problem with DirectDraw do you wish to not use it now?" (Or something like that... it asks me if I want to disable it). Clicking either yes or no, AO launches and works fine.

    I've had 3 other crashes, cannot tell if it's AO that crashes or if it's WinME. I'm sorry but I forgot to check the errorlog, but as soon as I get my hands on it I can post it here.

    My question, has anyone else have had this problem or does anyone from FC know about this?

    CPU: PIII 700MHz
    Motherboad: ABit BE6-II
    Memory: 256MB 100MHz
    Graphic: Hercules 2D Prophet DLX 8500LE 128MB DDR
    OS: Fecking WinME
    Drivers: The latest version of DirectX and graphic drivers from Hercules

  2. #2
    ATI cards seem to do that. It doesn't inhibit the game, but I've seen them do that when testing, and switching drivers. Perhaps it is a bad install of the drivers. Try uninstalling and reinstalling them.

    Then run dxdiag in the start->run and choose to run the direct draw test under the visual tab and then try the game.

    You might also want to try switching the graphics device in the hardware options. Or, turn on w-buffer support in the driver options menu (somewhere buried in display properties->settings->advanced->direct3d->more options or so) and use the w-buffer in the hardware options.

    Funcom Customer Service

  3. #3
    Thanx GM-Zixxax.

    I noticed that it didn't matter if you chose to run with or without DirectDraw when launching AO. The game booted up and nothing else happened. I tried with HAL and Lightning & Transform configs.

    I also ran the dxdiag and the test passed in both DirectDraw and Direct3D. Though it complains that the ATI drivers are not digitally signed but that shouldn't matter... right?!

    Well, I'm going to give it another try.

  4. #4
    Okay I've solved it.
    I came to the conclusion that it wasn't AO who complained at DirectDraw (maybe you knew), it was "dxdiag".

    I ran dxdiag as I posted in previous reply and now the error message doesn't pop up anymore. Only tested it in dxdiag and when it passed it never came up again.

    Though my frecking WinME keeps me from playing hours after hours in a row... ME ain't that good in dealing with the memory... random freezes are the most popular.

    New computer on it's way though

    Thanx again GM-Zixxax for the fast reply.

  5. #5

    Me too

    I've got the same problem, though for probably slightly different reasons. I upgraded my video card to a radeon 7600, and I now get the: There was a problem loading direct draw the last time this program was used, would you like to bypass it screen with the buttons. It's slightly annoying, but I can deal. However, I have noticed that I can run the tests in dxdiag and they all come up fine. Then, the message doesn't show up until I restart my computer. I think the problem is that I didn't upgrade the drivers for my intel chipset, because I couldn't figure that out. (Not a real Techie here by any means.) So, if anyone can possibly help me out in that area, it'd be appreciated.
    BattleReaper: noun; The blitzing armorer of Rimor.
    General of Fire Dragons
    Level 165 Solitus Fixer
    If you need it, and you've got the cash, I can get it for you.

  6. #6

    Angry Same problem... almost.

    Okay, so I've been at this since the new patch...


    Motherboard: Asus A7M266
    Processor: AMD Thunderbird 1ghz
    Ram: 768mb PC-1600 DDR
    Video: ATI Radeon 9000 pro
    Sound: SB LIVE! Platinum
    OS: Windows ME

    I have so far..

    Re-installed DirectX
    Re-installed Radeon Drivers
    Updated Bios
    Re-configured Bios
    Re-Re-installed DirectX
    Downgraded Radeon Drivers.
    Re-upgraded Radeon Drivers.

    Also tried lowering resolution, tried w-buffer, tried using HAL/T&L, 32-bit, 16-bit etc.. etc... No help at all..

    etc.. etc..

    Not only do I get the DirectDraw error EVERY time I boot the game, but I get to play for about 2 minutes before the whole thing freezes up on me and I have to reset the computer.

    Honestly.... I would really like to have an option for OpenGL for AO. It may not be quite as advanced, but at least it's fast and STABLE! I can't ever remember a time when I was running anything in OpenGL that it crashed my system.. maybe was glitchy.. but never crashed.

    Owell.. hopefully they will get this sorted out with ATI and we can all start playing again.

  7. #7


    Just out of curiosity, are you using dialup?

    When I first started playing AO I had the problem of the game crashing every 2 minutes. Turns out it was my modem...old p.o.s. Anyway, I switched over to my other computer, and now I don't crash (except rarely or when I try to enter trade)

    Your system sounds better than what I'm using, so I would assume you've got a decent modem or are using dsl or broadband. Anyway, I'd say look to your connection. I think the problem lies there somewhere. Now If I can only get them to fix the trade district for me...

    BattleReaper: noun; The blitzing armorer of Rimor.
    General of Fire Dragons
    Level 165 Solitus Fixer
    If you need it, and you've got the cash, I can get it for you.

  8. #8

    Unhappy Wow is this an odd beastie

    Heh, I have DSL 1.54 down, 384 up.

    I at least know it's not lag.. BUT! I have concluded the following.

    I don't think it's AO, DirectX, OR the ATI drivers at this point. All of which I have re-installed, and (with the exception of AO) have tried using previous versions of. DX8.0, 8.1, 8.1a and the ATI CATALYST 2.2-2.4 driver sets. None of which make any difference. I also removed the ATI 9000 pro and replaced it with an old Geforce 2 MX 32mb and get the same problem.

    The only thing I can conclude at this point is that Microsloth put out it's "critical" updates and that may have something to do with it. I would say that it's because I'm using WinME, but other folks have been having the same issue with win98, SE and 2K as well.

    I'm still looking, but it looks like I'm going to have to wipe my machine and re-install. Shame too, I've been running on this install of ME for almost 2 years now with no major problems. <sigh>



  9. #9
    I have a similar problem:

    Windows ME.
    -AMD 2200
    -512MB Memory
    -Hercules 3D Prophet 9000. (gotta verify exact number but pretty sure)
    -Don't remember motherboard. Must be Asus or Abit.
    -Directx 8.1

    The game let me choose between 4 adapters for display but only 2 of them are different.

    I'll check exact denomination but one is "DirectDraw" and the other is "somesuch and lightning".

    When I choose DirectDraw, the game always crashes within 5 minutes.

    When I pick the other choice, the game is much more stable but it does crash once in a while. When it does crash and I reload the game, it tends to be less stable than usual.

    On reload, I always get that dxdiag failure report.

    Sidenote : If I change my choice for adapter from the first menu (not logging into my account), that change is never saved.

    I'll edit this when I can complete the info.
    (If this board is still running...)
    The information above is highly classified and only available to worthy Omni-Tek employees; any individual spilling out this info to filthy rebels will be considered a traitor, cooked alive and fed to leets.
    Phloxom - Engi 86
    My Rimor QL50-120 market place
    Fallen Sword: Free web based MMORPG

  10. #10

    Unhappy Found the problem (sorta)

    I still get the Ddraw error, but now it's changed. I now actually GET an error message when I get to the desktop. ddhelp.dll (exe?) appears to be the culprit, or at least it is now. ddhelp by the way is a background proccess present in all versions of windows (even NT4) but unless you have a "task manager" you can't see it in win9x-ME. I don't think it has anything to do with Anarchy either. As soon as ddhelp goes awry, directX is no longer available and I have to reboot my machine. Don't know what the deal is, but I'm sure MS will put out another update soon and disguise it as some sort of "Security" update or something.

  11. #11
    i'll add my description.. not sure if it fits in. i never got any error message.

    win98se - fully updated
    amd 1.2ghz
    k7s5a lan - latest drivers, bios NOT updated
    DSL through router
    only background application is norton 2002 (if i disable it it wont make any difference)

    radeon 7500 64mb ddr - latest drivers
    asus v9180/td mx440-8x 128mb ddr - latest drivers
    .. no difference

    dx 8.1/9 .. no difference

    T&L / HAL .. no difference.. same for W/Z buffer

    ao re-installed .. no difference
    hard disk formatted, complete system re-install .. no difference

    windowed mode: game randomly freezes. maximum delay has been ~30 minutes (i thought ive got it.... doh)
    iam able to close ao with win task manager (ao is marked as "doesn't reply" then)..
    back to windows: starting ao again doesn't work. iam able to log in, but after clicking on "play" nothing happens expext a black window... :|
    start menu -> shut down -> restart: desktop fades into grey, cursor goes into "idle" .. then - system frozen -> reset button.
    (i also tried to press the reset button right after ao freezes without closing ao. always had to use "aorepair.exe" then)

    fullscreen: almost stable, but if i alt-tab into windows, ao always freezes or takes >1 minute to come back.

    makes me unable to play ao, because i HAVE to be able to access other programs, sites, emails, ..whatever very often. actually my account isnt worth the money.

    now... my girlfriend, sitting right next to me in front of:

    amd 1.2ghz
    k7s5a lan
    DSL through router
    dx 8.1

    gainward mx440 4x agp, 64mb ddr

    windowed: whatever she does, ao is running stable. no freezes at all.

    fullscreen: same here.

    now to go a bit deeper:

    ..her mainboard (same model as mine) was bought months later, so her bios is on a newer version.

    ..the manufacturers of our ram chips are different, but this has made no difference. already tried her ram chips in my computer

    ..i have a seagate baracuda with 80gb (c:15/d:65) hers is a seagate baracuda with 40gb (c:15/d:25)

    ..same monitors (running with same drivers), same mouse (also same drivers), standard keyboards (so no special drivers here)

    well.. next thing ill try is to upgrade my bios. bleh. if it doesnt work then, i dont know what i can do (switching computers is not possible)

  12. #12

    Unhappy This has seemed to pop up again

    I just started having a similar problem.
    My motherboard blew up and of coarse Windows just loves having the mb swapped on it. Re-installed windows over it's self. Re-installed all the drivers. Got the latest Bios and Via drivers for the mb installed. Went to Window's Update Site. Saw Critical Updates and DirectX 9. Downloaded and installed both. Now everything works fine except AO. Ran dxdiag. Got all the same errors and messages as listed above. Went through and ran all the tests. All tests passed. Tried AO again. Logged in and as soon as I tried to move or anything AO crashes. I'll list my specs if asked but from what I saw above I tend to agree that it seems to have to do with the Critical update or DirectX 9 or a combo of both. If any of you came up with a solution I'd be most gratefull.
    btw I never really had any problems with AO before. Oh, and I did try re-installing AO also.

    Decided to add that I use a Asus V8200 GeForce 3, am running Win 98 se and on a cable modem. All else is very similar to everyone above for the most part.

    Thanks for your assistance

    Last edited by Tasman; Apr 9th, 2003 at 06:19:45.

  13. #13

    Found the problem

    DirectX 9 was the culprit.

    *Note to self: Only do 1 thing at a time when repairing your system*

    Downloaded and installed DirectX 9.0a that was to fix problems with 9.0.

    9.0a was released March 26, 03. Went to nVidia's site and found a new driver (43.45) that was released March 27th and stated to be compatable with DX 9. All is well now.


  14. #14
    Mine.. ah.. won't even start up. After it says "Checking DirectX Capabilities" (I now notice the DirectX) it gives me an Illegal Operations message. Any of you know what this means?

    ANARCHY caused an invalid page fault in
    module ANARCHY.EXE at 0167:004117c7.
    EAX=00000000 CS=0167 EIP=004117c7 EFLGS=00010246
    EBX=016514d8 SS=016f ESP=006de8c8 EBP=006de910
    ECX=00000000 DS=016f ESI=006dfa5c FS=0d17
    EDX=004129a3 ES=016f EDI=bff55836 GS=0000
    Bytes at CS:EIP:
    8b 41 10 c3 55 8b ec 51 8b 41 0c 8b 4d 0c 83 65
    Stack dump:
    004129bd 006de91c 006de968 0000898c 00000002 0049a990 006de91c 0000898c 0046b889 0046a734 00000000 00000000 00000191 00000073 0047bf10 00000000

  15. #15
    This was my resolution to this issue:

    Unlike most of the replys here, I would crash no matter what I clicked: No dont use direct draw, or yes load without.

    I was in the middle of DLing the Ao fix utility when I noticed the rather old version of dxdiag in the funcom folder. Clicking on it I got a "this version of dxdiag is much older than the version of your video driver" and then it immediately gave me the SAME error msg I had been getting trying to run AO: Dxdiag has noted that the last time this program was launched there may have been...blah blah blah".

    Ran a search on my harddrive for a more recent version of dxdiag and copied it into my funcom folder...poof! No more direct draw/dxdiag AO crashes..hope this helps one person out there. =)
    Kudos fc on a expansion release about as smooth as they get.

  16. #16

    Yeppers ... had the same problem as Shikhan did ...

    As did several other players on Test Live.

    Found the old dxdiag.exe program under the Funcom folders.

    Deleted it.

    Everything works fine now.

    I'm on WinXP with a Asus V8460 (nVidia 4600 chip) and 43.xx drivers.

    Hope this helps ...
    Omni nano NT, Male, Level 200
    Council of Testers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts