Results 1 to 17 of 17

Thread: Connection terminating all the time after using a new Linksys Router

  1. #1

    Connection terminating all the time after using a new Linksys Router

    I have the problem, that I get kicked from the game all the time, since I have installed my new Linksys BEFSX41 Router.

    I can log in normally and play for some time and then get disconnected. When trying to connect again I just get the "Player logged in" message.

    Now my question is, if anybody knows that problem/knows what to do?

    I thought that maybe the FC server connects back in to the client and since it cant, the connection terminates. Dunno.. is this the case? And if it is, what ports should be enabled in the router/NAT translation?

    Would be grateful for some help!
    Epitaph Proud member of The Syndicate


  2. #2
    "If you are behind a firewall, or have firewall software installed on your PC, it needs to be configured to allow Anarchy Online access. Generally this is done by opening the following ports for the TCP protocol: 80, 7012, 7013 and 7500 - 7505."

    Most Router/Games kinda require you to use something like DMZ. But this leave a Hole in the Firewall.

    The Linksys routers 21/41 all seem to end up in alot of complaint posts. Could be theyre the most common.

  3. #3
    -Adding to Common Issues thread!

  4. #4


    Dude, I've used the BEFSR81 and I'm currently using the BEFSX41 without ever having to do anything to the router. I've also gone LD with the error msg that says i'm already logged in. You have to give the log in server time to properly disconnect you for you to try again. Becareful opening ports up.. Check out DSL Reports they have a good forum for Linksys products. The BEFSX41 has a new Firmware rev. That might help you out. Good Luck.
    Holding it Down in NYC!!!


  5. #5
    I ahve a Linksys router, it has always worked well, but today.. for no reasons it started ating weird.

    Only when I open AO, I lose my conenction to the router (cable unplugged message, no led) then it's ok just after that. I always get disconnected etc... never happenned before.. I tried everything I could find and still doesn't work.. resetted to factory defaults.. nothing works even like that..

    If someone finds a solution, I'd like to hear.. I'll keep trying to find out.. but I really don't know why it does that, only started today

  6. #6
    Driving me nuts. Here I am spending money and I cannot stay logged in very long. I know its the router cause if use mdoem direct it works fine. However, this is the first pain in the butt I have ever had.
    I had to do the forwarding before for Dungeon Siege for hosting. NO PROBLEMS
    I had to put in settings in for Dark Age of Camelot NO PROBLEMS.

    Router BEFSR41. I have even updated the stupid Firmware with no luck.

    Forwarding section

    80, 7012, 7013, 7500-7505 all TCP enabled. NO LUCK.

    I cannot ditch the router cause GF would like to surf the web also. She would like to join me in AO if that were possible.

    1.4MB down and I cant play AO on a Linksys Router. DOES ANYONE OUT THERE HAVE A FIX tired of the pointing the finger game back and forth. Am i missing some setting.. what gives.

  7. #7
    I use a Linksys BEFSR41 router and do not experience any problems. I am not sure what could be happening in your case. You might want to try specifying your computer on DMZ (do this in the router setup). However, this will expose your computer to the internet, so you would probably want to be running a software firewall.

    Best of luck to you Major Tom Servo.
    Assistant Director Etaks
    ARK Community Relations
    Social Guidelines
    ARK Web Site

  8. #8
    Try reseting your Router again, then re-enter your settings.

    Small black button on the outer casing of the router I believe.

  9. #9
    What kindá internet type u got??

    Connect on Demand: Max Idle Time Min.
    Keep Alive: Redial Period

    Do u have these 2 options in it?

    Sometimes if 1 of those options r set wrong... depending on ur internet conn ofcourse can disconnect u from the internet.
    Last edited by Ubdeadmeat; Jul 8th, 2004 at 09:40:30.

  10. #10
    Also, make sure that you have the hardware bios flashed. Linksys is famous for an issue where it resets itself around every 15 minutes. Invisible if you are just browsing but will consistantly interrupt online gaming.
    Information doesnt want to be free.
    It wants to be liberated and very expensive.

  11. #11

    But ...

    If that were true then wouldn't all comps connected to the router be disconnected if the router resets itself?

    My hubby and I both play and he hardly (if ever) gets disconnected. I, on the other hand, crash to desktop at the minimum once every half hour and worse case system reboots itself.

  12. #12
    I personnal have used the BEFSR21( I think this is the Model ) and even 2 years ago EQ tech support had this listed as a known HARDWARE problem and not to use it with EQ, not because of their bad programming but because of so many users with complaint using them.

    My personal experience with the Router was it was CRUD. I played AO and CS, and Wife did Internet and son did CS with me at same time. I would experience at random times with no true interval periods a constant DISCONNECTION from CS server where he would stay connected. Then an Inability to reconnect without rebooting my computer. I would lose connection and experience ping spikes while wife was switching websites. This was all with the fastest cable service.

    Rebooting my computer would lead to the fact it was something wrong on my computer. After several new Hardware upgrades and driver checks, I finally said this is BS and threw the Router out the window. FIRMWARE did nothing to change the issue.

    I went and bought me a SWITCH and requested another IP ($5) from my cable provider and problem went away.

    But, others have expressed no issues with the router or have stated that firmware fixed their problems.

    Good luck on this issue.

    I, on the other hand, crash to desktop at the minimum once every half hour and worse case system reboots itself.
    This would lead me to belive there is a Conflict with Hardware or Drivers, or even HEAT issues.
    Last edited by GreyBear; Jul 13th, 2004 at 20:43:18.

  13. #13

    settings i have messed with. I am stuck and do not know what to do at this point except maybe buy a new router.

    In the following pic you can see the port triggering..

    Even gone as far setting up a dmz host.. stuck in my ip address like i have done before for Dungeon Siege. Even stuck in my own mac address.

    stuck in 7012 7013 7500-7505 and 80 in the lovely ext port with of course the dmz ip address.. all tcp and i cannot stay connected.

    Getting frustrating. Got on help with linksys online. suggested i remove all those port settings and triggering.. Wow.. I only lasted 2 minutes.

    If could get this thing to work would be great.. Otherwise would say post that maybe Linksys is a common lemon problem with a variety of online games.

    checked with my ISP nothing is blocked.. Of course once again if I ditch the router and go direct modem I can play to my hearts content. While, everyone else gets mad for no internet.

    DMZ for one person isnt really gonna help. I would like to play with a friend over with me..

    If light can be shined that be great.

    BTW i have tried setting up my local network card settings to the same dns and setting up a manual ip.

  14. #14
    I personally use Belkin/Dlink for my home routers. I would recommend maybe using a software firewall instead of a hardware. In all realism, the fact that you are using a router will discourage most script kiddies from hacking your system. As long as they dont get past your router, most use non routable IP addresses which means that they might be able to get into your router, but using that to hack into you home systems is going to be an all day sucker, which is more trouble for most then it is worth.

    As long as you keep your OS updated for security patches and don't run any remote software (pcaw, etc.) you should be safe. If you feel that paranoid or think that the stuff you have in your system is worth while for someone to spend hours getting in, then run something like a personal firewall for your systems. Much easier to work with then setting up pinholes or DMZs. In fact, if you are using a DMZ, you might as well not have the firewall there in the firstplace unless your DMZ is correctly configured to not be part of your IP schema on your network or is before the router/firewall, that system in the DMZ is WIDE open.

    And I agree with GreyBear. If your crashing/Locking up then that is NOT an issue with your router. Might be heat/hardware/software (malware, memory leaks, etc.).
    Information doesnt want to be free.
    It wants to be liberated and very expensive.

  15. #15
    I had this exact same problem about two years ago. I tried forwarding the ports, upgrading firmware, and changing numerous settings. But the only thing I found that worked for me was removing the DMZ from the computer I was playing on (i.e., setting it to another computer on the network, or turning it off completely).

    I am completely certain that having the DMZ host set to myself was the problem, as many times after I stumbled upon the fix, I would be disconnected after turning the DMZ on and forgetting to remove it.

  16. #16
    I also have a Linksys router and I had a similar problem once.

    I didn't find any settings that could make it work.

    The solution?

    Unplugged modem and router for an entire night. Did a couple of router reset to default (maybe 3-4).

    Plugged back everything in... and works fine now.

    Sometimes it's just the simple things that re the best things to do.
    Sage Forums Advisor Rokinar
    ARK Community Relations

    ~{ Advisors of Rubi-Ka }~
    ~{ Social Guidelines }~

  17. #17
    I think I am gonna just throw away the linksys router and get something different. I am tired of dealing with this piece of equipment.

    I was thinking about upgrading to the following listed below.

    NETGEAR 4-Port Cable/DSL Web Safe Router with 10/100Mbps Switch, Model RP614


    D-Link Express EtherNetwork 4-Port Ethernet Broadband Router, Model DI-604

    Anyone have any problems/experiences with either of these two?

    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts