Results 1 to 8 of 8

Thread: kkr.dll causing constant crashes - says bug report

  1. #1

    Angry Constant Crashes - Bug Report says Fault at kkr.dll

    AO is crashing every 2-5 minutes with the exact same problem each time. I have updated/downdated ALL drivers, shut off firewall/virus programs, dumbed down all video settings and it still is crashing. The game is unplayable. Here is the first portion of the bug report:

    Exception code: C0000005 ACCESS_VIOLATION
    Attempted write to: 00000001
    Fault address: 00E851E4 03:000691E4 C:\Program Files\Funcom\Anarchy Online\kkr.dll

    Asus A7V8X, AMD 3000+ 333FSB
    1 Gb Corsair RAM
    GeForce FX 5900
    160 GB Maxtor SATA Drive
    Sound Blaster Audigy

    Any ideas/suggestions/fixes would be GREATLY appreciated.

    Last edited by Dorkyn; May 14th, 2004 at 00:33:20.

  2. #2
    Sounds like possibly bad memory.

    Do you have any other problems with any other programs other than AO?

    If you know what your doing I would suggest a data backup and reinstall of your Operating System, and re-install of AO. If you don't know how to do all that, and your not having any other problems then post here and ill check back tommorow and research it some more.

    (yes, to everyone who thinks re-installing is drastic I realize it is a big step, but when you have worked with microsoft products long enough you learn the path of least resistance, and re-installing is that path)

    A google search for kkr.dll didn't show anything, so that means you pretty much have a MEGA rare problem, and that indicates there is something wrong thats specific to your computer.

    Lemme get you a URL for a memory testing program.....

    Go here.....

    and download.............

    Download - Pre-Compiled Memtest86 v3.1a installable from Windows and DOS

    and run that bad boy for awhile so we can make sure that your memory is good to go first.

    If your memory checks out as good, before re-installing your operating system, you may want to try re-installing AO and see if that helps.


  3. #3
    I see you have corsair memory and a pretty recent processor (not to mention your other components - nice SATA drive!) which indicates to me that you might have built this yourself and was aiming at performance. You might want to glance over your RAM timing settings in your bios and make sure you're not pushing things TOO hard. Overclocking the RAM or/and the CPU is also a common problem. Also, AO is an INTENSIVE system resource utilizer. If you have ANY weaknesses in your system, they often appear when running AO.

  4. #4

    Unhappy Thanks for the input

    Hey thanks guys.

    I know enough to be dangerous. I did build the system myself, I only have the CPU slightly overclocked, I will turned in down. Nothing else is overclocked. I will check out the timing on the RAM (Corsair XMS 3500).

    I have downloaded the memory testing program, and will run that next as well.

    Man I don't want to reinstall everything again!! I just put that new hard drive in a month and a half ago - oh well, gotta do what you gotta do. I will try your suggestions first.

    Thanks again, I will let you know how the mem test goes.

  5. #5
    Try to grab the recommended (default) settings for that ram (I have xms corsair ram too but DDR333 instead). I would try setting your timing to the 'specs' and getting your cpu back to normal speed. How's your cooling also? Hopefully you have a way to monitor your temperatures in the case (cpu and system) and voltages. Double check all of that. You never know, there could be a hardware issue if it's not related to software or the bios/overclocking.

    (check these things before reinstalling your OS, you did just do that anyway)
    As Sky says above, please do post back your results!

  6. #6

    Talking IT'S FIXED

    Thanks for the help. It was a combo of RAM settings and overclocking. I only had it bumped up one step, but that and the RAM weren't getting along. I set EVERYTHING back to normal and that has fixed the problem. Kinda weird, I haven't had a problem with any other game except AO! Oh well, thanks again, I REALLY appreciate you guys taking the time!!

  7. #7

    Angry helllo

    i got a message after crashing, about 15 time that is, that, well take a look:

    Exception code: C0000005 ACCESS_VIOLATIONAttempted write to: 00000014 Fault address: 008BBCC4 01:0006ACC4 C:\randy31.dll

    SS:ESP:0023:0012F270 EBP:00000000
    DS:0023 ES:0023 FS:003B GS:0000
    Fpu control: 0x9001f

    Stack: From adr 0012F27008F986B8 0012F558 00000000 0000F24D 00000001 0012F4A8 00000003 00000000 0012F530 008BCFF9 08F986B8 0012F380 08E4ECC8 008BDB65 0012F380 08E4ECC8 00000000 0012F380 008BB107 0012F380
    00000001 0012F380 008BB315 0012F380 0000F5E9 00865FFF 0012F380 00000001 0012F2FC 0012F380

    Call stack:Address Frame Logical addr Module008BBCC4 00000000 0001:0006ACC4 C:\randy31.dllThe current module has no framepointer. Unable to backtrace the callstack.<end>

  8. #8
    Quote Originally Posted by hardcoregamer
    i got a message after crashing, about 15 time that is, that, well take a look:

    That would be the game engine dll.
    5 years on and it still doesn't work properly.

    Caloss2 LVL 220 melee VANGUARD (semi retired).....Llewlyn 220/30/70 meepmeep.....Boooocal 220../30/70 Soldier.......Knack 220/30/70 Keeper.....Hiesenberg 215/xx/xx NT NERFED Neytiri1 220/30/70 Shade Knacker220/30/70Meat shield for guides/walkthroughs/letsplays and all your other AO needs
    Quote Originally Posted by Mastablasta
    In my special design documents that I feed to the FC devs, who are my willing slaves.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts